Author Topic: Dead Power Supply??  (Read 1913 times)

Offline wiiarethesound

  • BCC n00b
  • *
  • Posts: 1
  • Karma: +0/-0
  • Who dat'?
    • View Profile
Dead Power Supply??
« on: July 19, 2015, 07:37:17 am »
Yesterday I was playing a game (Middle-earth: Shadow of Mordor, if it matters ;)) when my computer suddenly shut down on me. At first I thought my power had gone out because it seemed like it had just lost power. When I realized that wasn't the case I felt the back around the power supply and it felt quite hot, so I thought maybe it had overheated. However, today when I went to try and turn it on I still got nothing. I opened the side panel and I can see that my graphics card still is getting power, as there are two green LEDs lit up. When I unplug the power supply, or simply turn it off, these two lights turn off. Also, after switching the power supply off and on again, I can press the power button on the front of the case and see that the fans for the CPU and GPU move ever so slightly. It looks like they get a small surge of power and then shut down again. This only happens the first time pressing the power button after switching the power supply off and on again. Pressing it again yields no results. This leads me to believe that my power supply is toast. Any other theories? Thanks for any help!

Offline Zeus

  • I AM Canadian!
  • BCC Admin
  • Hard Modder!
  • *****
  • Posts: 3616
  • Karma: +678/-200
  • Gender: Male
  • [S]odbuster
    • View Profile
    • BCCHardware
Re: Dead Power Supply??
« Reply #1 on: July 19, 2015, 11:08:28 am »
It sounds like a PSU failure to me. Unfortunately, it could be a couple of other things. Troubleshooting it, I would see if I could borrow a friends PSU first and see if that is the issue. If it still doesn't run, it could be a motherboard issue as well. Those are the two most-likely culprits of this failure. But the first (and most obvious) thing to test is the PSU with a loaner if possible.

What brand/watt of PSU are you running and your system CPU/GPU specs?