Author Topic: Disabling Win2k Virtual Memory  (Read 7189 times)

Offline BoneRak

  • Waiting to be Banned.
  • Case Whacker
  • ***
  • Posts: 269
  • Karma: +10/-2
  • Gender: Male
  • I'm not camping, It's a picnic!
    • View Profile
Disabling Win2k Virtual Memory
« on: August 27, 2003, 09:29:50 AM »
I was wonding how to disable the windows 2000 virtual memory as I heard that could speed my game up. And when this is done do it always warn you when you start windows that there is no page file?

Offline VE6JHC

  • Case Whacker
  • ***
  • Posts: 488
  • Karma: +2/-0
  • Heat Removal by H20
    • View Profile
Re:Disabling Win2k Virtual Memory
« Reply #1 on: August 27, 2003, 11:09:31 AM »
You set the size of your page file.....This improves performance because Windows does not have to monito and continually adjust the swap file size....To adjust your page file got to control panel/system/advanced/performance/advanced/virtual memory/change....A rule of thumb is to set your page file at double your installed ram size.
Video Games will send you straight to Hell and Satan has a Rail Gun!

Offline Zeus

  • I AM Canadian!
  • BCC Admin
  • Hard Modder!
  • *****
  • Posts: 3616
  • Karma: +678/-200
  • Gender: Male
  • [S]odbuster
    • View Profile
    • BCCHardware
Re:Disabling Win2k Virtual Memory
« Reply #2 on: August 27, 2003, 06:35:39 PM »
You set the size of your page file.....This improves performance because Windows does not have to monito and continually adjust the swap file size....To adjust your page file got to control panel/system/advanced/performance/advanced/virtual memory/change....A rule of thumb is to set your page file at double your installed ram size.

The whole point is that he wants to disable the page file.  D-man has done it successfully on WinXP, but every time I try it one Win2K it warns me upon rebooting.  After doing a bunch a surfing in other forums, I've read that it really doesn't improve performance.  If you set a page file (of any size), it will only be used when your system runs low on RAM.  If you are running 1GB+, you probably won't use your page file at all.

This can be verified several ways, one is by running System Works, and monitoring the pagefile size.  I have mine actually set to 256MB (just in case I use more than 1GB of RAM).  I run the monitoring tool on my second monitor and my page file never budges. . . even when loading UT2003 Face3 or any other maps.  My system ram is fine.

From what I've gleaned BoneRak, you can't disable it entirely in Win2K.  You may be able to set it to 0MB though. . . .hmm.  I'll have to get off Xena's laptop and go give it a shot.

Offline BoneRak

  • Waiting to be Banned.
  • Case Whacker
  • ***
  • Posts: 269
  • Karma: +10/-2
  • Gender: Male
  • I'm not camping, It's a picnic!
    • View Profile
Re:Disabling Win2k Virtual Memory
« Reply #3 on: August 30, 2003, 02:43:06 PM »
Thanks for the info. I set mine to 0 and when I go to start a game or anything, it pops up and says it's adding 20MB to the swap.